User Tools

Site Tools

en


rikumnk2

This addon requires TensorCore!
Make sure you have TensorCore installed from the Minion Store

endwalker monk routine

Check RikuMNK for the Shadowbringers wiki while this one is under construction.

rikumnk2.txt · Last modified: 2022/01/11 21:40 by anyone